Likes Likes:  0
Thanks Thanks:  0
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: 2009 Reverse not working

  1. #1
    30+ Posts
    User ID
    3095
    Join Date
    Jul 2010
    Location
    Hardin Ill
    Posts
    36
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    91

    Default 2009 Reverse not working

    I have a 2009 triglide that has a reverse that has stopped working, after shifting into neutral I push the reverse button and the light comes on, but nothing happens when push the down arrow. Any ideas? Thks, Chuck

  2. Love Jugs
  3. #2
    2500+ Posts trikermutha's Avatar
    User ID
    3584
    Join Date
    Oct 2010
    Location
    USA
    Posts
    2,611
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    159

    Default Re: 2009 Reverse not working

    Quote Originally Posted by tri glider View Post
    I have a 2009 triglide that has a reverse that has stopped working, after shifting into neutral I push the reverse button and the light comes on, but nothing happens when push the down arrow. Any ideas? Thks, Chuck
    Did you check the circuit breaker under the I think the right side cover?

    There is a reset button to press if it was tripped. Like a circuit breaker.

  4. #3
    30+ Posts
    User ID
    3095
    Join Date
    Jul 2010
    Location
    Hardin Ill
    Posts
    36
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    91

    Default Re: 2009 Reverse not working

    Thks trikermutha, I just looked under the right side and didn't see anything that looked like a breaker. I then looked behind the left side and found a fuse box, but it didn't list anything indecating reverse. Thks.

  5. #4
    200+ Posts Boom's Avatar
    User ID
    2564
    Join Date
    Mar 2010
    Location
    Sarasota, FL USA
    Posts
    216
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    101

    Default Re: 2009 Reverse not working

    I think the '09s had the breaker under the seat. Maybe oldmsocko will jump in since he has an '09 also.
    2010 RHS Tri-Glide Ultra, Fuelmoto stainless headpipe, Supertrapp SE slip-ons, SE255 cams w/S&S lifters and TTS2 tuned by Docs Performance, Lenale parade fan, UltraCool Reefer oil cooler, ClutchWiz, Barnett+1 clutch pack. Hayden chain tensioner, crotch-cooler shields, Wild1 WO575 chubbies, Road Zeppelin air seat, 30t. primary belt pulley, Lyndall rear ceramic/aluminum rotors w/L. pads rear and front, Garmin Road Tech 660 w/radio interface, 1.25" lift brackets

  6. #5
    2500+ Posts trikermutha's Avatar
    User ID
    3584
    Join Date
    Oct 2010
    Location
    USA
    Posts
    2,611
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    159

    Default Re: 2009 Reverse not working

    You know I think you are correct!!! I looks like a square device with wires on both sides on it and has a arm with a push button reset on it..

    It looks something like my picture..but not the actual part..just a example

  7. DKCustoms postbit
  8. #6
    20+ Posts
    User ID
    7851
    Join Date
    Apr 2012
    Location
    Front Royal, Virgina,USA
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    77

    Default Re: 2009 Reverse not working

    2009 is under the seat. One of the dumbest places to put it! HD thought so too that's why it got moved on newer models to the right side.

  9. #7
    30+ Posts
    User ID
    3095
    Join Date
    Jul 2010
    Location
    Hardin Ill
    Posts
    36
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    91

    Default Re: 2009 Reverse not working

    Thks guys, now do you have to remove the tour pack to take off the seat?

  10. #8
    30+ Posts
    User ID
    3095
    Join Date
    Jul 2010
    Location
    Hardin Ill
    Posts
    36
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    91

    Default Re: 2009 Reverse not working

    Guys, I checked under my seat, but didn't find anything that looked like a breaker. Any more ideas? Thks

  11. #9
    Contributing Member SEAlaskan's Avatar
    User ID
    2257
    Join Date
    Nov 2009
    Location
    Juneau, Alaska
    Posts
    312
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Rep Power
    111

    Default Re: 2009 Reverse not working

    Quote Originally Posted by tri glider View Post
    Guys, I checked under my seat, but didn't find anything that looked like a breaker. Any more ideas? Thks
    Look under the cross plate that the passenger hand hold is mounted to, you'll also see the reverse motor under there.
    Butch

  12. #10
    1500+ Posts
    User ID
    2140
    Join Date
    Sep 2009
    Location
    North East Ohio
    Posts
    1,613
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    139

    Default Re: 2009 Reverse not working

    Quote Originally Posted by SEAlaskan View Post
    Look under the cross plate that the passenger hand hold is mounted to, you'll also see the reverse motor under there.
    Butch
    That is exactly where it is located, right under the seat to the rear

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Reverse not working
    By DK Custom Products in forum Harley Trike Conversions
    Replies: 26
    Last Post: 09-04-2018, 04:15 PM
  2. A/C not working?????
    By Backdraft in forum Stallion Trikes
    Replies: 6
    Last Post: 09-27-2013, 07:30 PM
  3. Clock not working
    By rickt in forum Honda Trikes
    Replies: 4
    Last Post: 08-28-2013, 10:44 AM
  4. Not all of us were working today......
    By werewolf in forum General Discussion
    Replies: 2
    Last Post: 05-21-2013, 09:51 PM
  5. Calendar is working
    By Lucky in forum General Discussion
    Replies: 1
    Last Post: 01-06-2013, 02:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •