Likes Likes:  0
Thanks Thanks:  0
Results 1 to 9 of 9

Thread: electrical

  1. #1
    150+ Posts
    User ID
    3941
    Join Date
    Dec 2010
    Location
    oly,wa
    Posts
    198

    Default electrical

    Goodmorning

    i have an electric germlin, my instrument lights flash, esecpially the mileage readout, tach lights, volt and psi guages. my cruise control works sometimes. I thought it was ground. any suggestions

    Thanks

    Dragon

  2. #2
    9500+ Posts Jack Klarich's Avatar
    User ID
    24367
    Join Date
    Oct 2016
    Location
    Jax, Fla USA
    Posts
    9,595

    Default

    Check your battery voltage first

    Next check the voltage with engine running, you could possibly have a bad regulator

    All electrical problems start @ the battery

    A simple load test of a fully charged battery ( 12.7 volts) Turn on headlights engine not running with a voltmeter on the battery

    If after 5 seconds your voltage drops below 10 volts you have a bad battery

    Good luck
    Nuff Said," Were Burnin Daylight, Lets Ride"(Sober 32years)
    Current ride : 17 FREEWHEELER M8, Power Vision tuner, DK Customs Outlaw air cleaner, modified by me head breather vent with drain, Gutted stock mufflers, (RJS Originals) rear wheel discs , (RJS Originals) custom windshield lower panel, Mighty Mites Love Jugs fans by Papa Zook

  3. #3
    200+ Posts
    User ID
    26009
    Join Date
    Feb 2017
    Location
    Arp, TX - USA
    Posts
    235

    Default

    About the only thing all of those items have in common is the smart junction box (fuse box under the seat). If it's been exposed to moisture it may have corrosion inside causing random issues. The "easiest" way to check is to unplug the connectors & look down inside the panel (light may help) to see if there are signs of corrosion present.

    If it is corrosion I don't know if you'll be able to effectively "clean" it & restore normal function & may have to source a replacement from a Ford vehicle (far cheaper than getting a new one from Ford).

  4. #4
    1000+ Posts tomg's Avatar
    User ID
    2213
    Join Date
    Oct 2009
    Location
    Titusville, Florida
    Posts
    1,057

    Default

    There has been a member who actually had standing water in the bottom of the fuse box under the seat. After disconnecting as mentioned above, the bottom was cleaned up , dried completely and put back together. As far as I know, he hasn't had any further problems. He did make a cover as his Stallion did not have one, out of a heavy plastic maybe a heavy duty leaf bag. Tomg

  5. #5
    Moderator
    TrikeTalk Moderator
    FuzzyWuzHe's Avatar
    User ID
    18134
    Join Date
    Dec 2014
    Location
    Grand Junction, Co. USA
    Posts
    12,000
    FT Author
    1 Thread

    Default

    Alan hates electricity ... but ... intermittent problems are generally a ground that has corrosion or loose ... or ... water in a connection.

    Both have been mentioned, so I'm just confirming.
    2014 Tri Glide - Fat Bottom Girl, 2006 Gold Wing Comfort Navi Abs - Jessica, 2003 Gold Wing - Helga, 2014 HD Ultra Limited - Harley Quinn, 2008 Gold Wing with Champion Conversion - Fat Bottom Girl 2, 2001 Goldwing - Tweety, 2015, HD Triglide - Fat Bottom Girl, 2011 HD Ultra - Raven, 2006 K1200LT - Vianca, 2007 HD Ultra - Ice Blue, 2006 HD Ultra - Arctic Blast, 2004 Honda Goldwing - Snow White, 2001 Goldwing - Crimson Pearl, And Many More

  6. #6
    9500+ Posts Jack Klarich's Avatar
    User ID
    24367
    Join Date
    Oct 2016
    Location
    Jax, Fla USA
    Posts
    9,595

    Default

    Quote Originally Posted by FuzzyWuzHe View Post
    Alan hates electricity ... but ... intermittent problems are generally a ground that has corrosion or loose ... or ... water in a connection.

    Both have been mentioned, so I'm just confirming.
    You might be surprised how loose and corroded battery connections cause more problems, especially on modern day ECM controlled vehicles

    When ever I am hunting an electrical problem I ALWAYS start @ the battery. JMO
    Nuff Said," Were Burnin Daylight, Lets Ride"(Sober 32years)
    Current ride : 17 FREEWHEELER M8, Power Vision tuner, DK Customs Outlaw air cleaner, modified by me head breather vent with drain, Gutted stock mufflers, (RJS Originals) rear wheel discs , (RJS Originals) custom windshield lower panel, Mighty Mites Love Jugs fans by Papa Zook

  7. #7
    150+ Posts
    User ID
    3941
    Join Date
    Dec 2010
    Location
    oly,wa
    Posts
    198

    Default

    thought I would give an update on my problem. I started at battery took it out had it tested(is only 6 months old), put it back in check charging and alternator. all ok, I went to the fuse box pulled all fuses and connectors put more die-electric grease on all again. (cleaned this up couple years ago and added die electric to everything). well I went to Yellowstone and back 1700 miles, cruise control worked for about 600 miles and quit. I got about 200 miles from home it started raining, cruise control started working, volt meter and psi meter started working, been working 3 weeks now are laughing at me.

    Dragon

  8. #8
    350+ Posts rocket1lf's Avatar
    User ID
    16700
    Join Date
    Dec 2013
    Location
    Hot Arizona, USA
    Posts
    356

    Default

    Quote Originally Posted by Dragon View Post
    thought I would give an update on my problem. I started at battery took it out had it tested(is only 6 months old), put it back in check charging and alternator. all ok, I went to the fuse box pulled all fuses and connectors put more die-electric grease on all again. (cleaned this up couple years ago and added die electric to everything). well I went to Yellowstone and back 1700 miles, cruise control worked for about 600 miles and quit. I got about 200 miles from home it started raining, cruise control started working, volt meter and psi meter started working, been working 3 weeks now are laughing at me.

    Dragon
    We would never do that Rick
    If you got to ride, ride in style
    Stallion #378
    Suzuki Burgman 650

  9. #9
    Moderator
    TrikeTalk Moderator
    FuzzyWuzHe's Avatar
    User ID
    18134
    Join Date
    Dec 2014
    Location
    Grand Junction, Co. USA
    Posts
    12,000
    FT Author
    1 Thread

    Default

    Quote Originally Posted by rocket1lf View Post
    We would never do that Rick
    Amen ... I would never laugh at someone with electrical problems ... I have however been praying I don't catch the gremlins ...
    2014 Tri Glide - Fat Bottom Girl, 2006 Gold Wing Comfort Navi Abs - Jessica, 2003 Gold Wing - Helga, 2014 HD Ultra Limited - Harley Quinn, 2008 Gold Wing with Champion Conversion - Fat Bottom Girl 2, 2001 Goldwing - Tweety, 2015, HD Triglide - Fat Bottom Girl, 2011 HD Ultra - Raven, 2006 K1200LT - Vianca, 2007 HD Ultra - Ice Blue, 2006 HD Ultra - Arctic Blast, 2004 Honda Goldwing - Snow White, 2001 Goldwing - Crimson Pearl, And Many More

Similar Threads

  1. Electrical problem/question
    By nevtat in forum Harley Trike Conversions
    Replies: 7
    Last Post: 09-12-2010, 02:13 PM
  2. I have an electrical problem! Help!
    By Boscoporp in forum General Discussion
    Replies: 3
    Last Post: 04-01-2010, 03:57 PM
  3. electrical problem, volt meter in 12v range
    By silverdevil in forum Stallion Trikes
    Replies: 8
    Last Post: 03-12-2010, 11:50 PM
  4. Electrical Problem - Blowing Fuse
    By patriot in forum Honda Trikes
    Replies: 12
    Last Post: 10-15-2009, 08:50 AM
  5. Electrical Woes
    By Ozarkryder in forum Honda Trikes
    Replies: 5
    Last Post: 06-15-2009, 08:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •