Likes Likes:  2
Thanks Thanks:  1
Results 1 to 6 of 6

Thread: Horn not working.

  1. #1
    30+ Posts
    User ID
    32733
    Join Date
    Sep 2021
    Location
    lake wales fl. USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    22

    Default Horn not working.

    2011 HD tri glide ultra. Had my radio fixed and got it put in now the horn does not work. The horn is ok and can here the relay working but no horn. Looked for info on how to replace the relay. Tested the horn with jumper's and it worked fine. Figured the contact is wore out on the relay. Any help is appreciated. Old Hippie.

  2. Love Jugs
  3. #2
    Thumper
    Gold Club Member
    1dn5up's Avatar
    User ID
    21022
    Join Date
    Nov 2015
    Location
    Bear Mtn. NY
    Posts
    20,445
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    300

    Default

    If the new relay doesn’t do the trick , then it’s wire tracing time
    2012 Triglide Piaggio MP3 500 to get groceries 1991 FLHS as back up
    "Better to have it and not need it than need it and not have it !"
    Tiffany, Olive, Daisy, “The Three Musketeers” together again.

  4. #3
    30+ Posts
    User ID
    32733
    Join Date
    Sep 2021
    Location
    lake wales fl. USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    22

    Default

    Quote Originally Posted by 1dn5up View Post
    If the new relay doesn’t do the trick , then it’s wire tracing time
    That is what I am afraid of. Going to order a new relay and hope that fixes the problem. After all it is 11 year old bike and electrical component's do go bad. It make noise but that dose not mean that the contact's in side are making contact. Wish me luck. Maybe time to buy a new bike. LOL. Thanks for the info.

  5. #4
    2000+ Posts Burnerboy's Avatar
    User ID
    23660
    Join Date
    Sep 2016
    Location
    Springfield, Mass. USA
    Posts
    2,077
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    134

    Default

    Please keep us ALL posted on what you found, (what the problem was) My eye /ears r open

    Thank you

    Ronnie

    2/6/22

  6. #5
    30+ Posts
    User ID
    32733
    Join Date
    Sep 2021
    Location
    lake wales fl. USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    22

    Default Horn relay

    I have looked everywhere for the new relay. Even looked on the HD order page no luck. So, all my dealers are close tomorrow and will have to wait till Tuesday. Will see what they say.

  7. DKCustoms postbit
  8. #6
    30+ Posts
    User ID
    32733
    Join Date
    Sep 2021
    Location
    lake wales fl. USA
    Posts
    35
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    22

    Default Horn not working

    Found the relay under the plastic wire cover at back of gas tank. Bought a stethoscope at harbor freight for mechanics. Helped me to locate the relay. All the Led light connectors where in the way just in front of the batterie. There is where I found the relay. Thought the relay was fed from the fuse box but it had its own fuse connector and hooked straight to the batterie. Don't figure. Hooked the hot wire up and all is well. Now going to clean up that Led light wiring and move all the connections to the fuse side cover. Never have I seen such a mess. So, my bike is a 2011 Ultra Tri Glide and still after looking at the wiring diagram have not found that relay on the diagram. Guess only a Harley mechanic is the only one who know where this relay is located. Hope this help's someone else out if you are looking for what is wrong with the horn not working but can here the relay clicking but can't find it. So back riding and enjoying being back on the road. Also, now able to play my CD's when ridding. Or play the radio. Have fun and rubber side down. LOL.

Similar Threads

  1. Cruise Control Not Working...
    By Markie in forum Stallion Trikes
    Replies: 20
    Last Post: 09-02-2015, 01:36 PM
  2. tail lights not working.
    By Biker-Dave in forum Harley Trike Conversions
    Replies: 8
    Last Post: 04-20-2012, 06:26 PM
  3. Turn signals not working
    By Las Vegas Biker in forum Stallion Trikes
    Replies: 5
    Last Post: 01-07-2011, 12:01 PM
  4. Driving Lights not working
    By Big Dog in forum Stallion Trikes
    Replies: 1
    Last Post: 05-09-2009, 07:33 PM
  5. gauges on dash not working
    By newtriker in forum General Discussion
    Replies: 2
    Last Post: 01-19-2009, 09:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •